Hello,

This is my first post to the list, so please be forgiving if I make
mistake. :)

I have checked the new prototype, and after a few hours I ran into a
problem. It seems the method of Enumerable.include has been changed.
It uses === operator instead of ==. The documentation attracts
attention that is just checks value, not type. The example in the doc
- [1, 2, '3', '4', '5'].include(3) - returns false in 1.6.0_rc0
instead of true as the doc says.

I tried to search a bug in trac, or a post here in the list, but I
didn't find anything about this change.

I don't know it's calculated or not, but unfortunately this breaks
down the setValue for select elements if I tried to set integer values
for a select. (Option values are always string.)

Is there a reason for this change? Thanks in advance!


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/prototype-core?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to