The alternate syntax suggested by Ben Newman and supported by Alex is
demonstrated in these two pastes: (Ben) (Alex)

The syntax is slightly more verbose than what we have in 1.6.0, but with it
it's dead easy to have true privacy for variables and methods. As Alex shows
in the last thread, it's also simple to implement in just few lines of code.

I would like to hear how do the others feel about this syntax. Core members:
would we want to support this in the framework?

You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at

Reply via email to