Kangax looks good.
I think that it should be $() instead of $W(), but for the purpose of
clarity during the
discussion the use of $W is fine.

I think that any method that returned element, will instead return
Any method that returned an array of elements will return a
(In implementation I think $$() should be used but for discussion $
$W() will be used
to avoid confusion)


I think we should follow jQuery's lead here and extend the
Element.Methods and Enumerable methods
to the NodeListWrapper.
$$W(...).each, $$(...).without, ... $$(...).hide(), $$(...).observe

If the node list returns 1 element then methods like $$
(...).getValue() should return the value of that element.
(this is how jQuery handles it)

I think $A should return a ListWrapper, maybe ListWrapper could be the
$super for NodeListWrapper.
ListWrapper would have methods of Array Additions and Enumerable

You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 

Reply via email to