another thing...

I recently used the Object.extend for the "default options" of a
So I just thought would it not be simpler to use an attributes' order
like this: Object.extend(from, to ) or Object.extend(source,
instead of Object.extend(destination, source). I mean it is just a
matter of conversion but I would rather prefer the logically order
"from" -> "to".

regards Tom

On 8 Jan., 22:22, kangax <> wrote:
> On Jan 7, 9:45 am, "joe t." <> wrote:
> > How would the core feel about a safe version of Object.extend?
> > Object.extend = function(destination, source, safe) {
> >   safe = !!safe || false;
> You don't really need this conversion - `&&` (the one that's in the
> loop) already does it implicitly.
> [...]
> --
> kangax
You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to
To unsubscribe from this group, send email to
For more options, visit this group at

Reply via email to