> `hasValue` as a replacement to `present` or as a wrapper around
> `getValue().empty()`?

The former. Element#present just sounds weird for SELECT elements,
imho. And hasValue seems consistent with the rest of the API (get|set|

> In general, I'm not excited about adding another
> method until we introduce wrappers.

Oh, yeah, me neither.
You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to