Hey Andrew,

Aren't all functions constants, in that sense?  Function.EMPTY isn't
more or less constant than Element.extend.

-- T.J. ;-)

On Oct 15, 1:08 am, Andrew Dupont <goo...@andrewdupont.net> wrote:
> Weighing in again, decades after starting the thread.
> First, I'm fine with calling it Function.IDENTITY instead of Function.K.
> On Sep 25, 2009, at 1:26 AM, T.J. Crowder wrote:
> > Make sense.  Shouldn't that be Function.empty and Function.k, though,
> > to follow our naming rules?  And perhaps Function.k should have a more
> > meaningful name.
> I'm very much in favor of all-caps, or at least initial caps, to  
> indicate that these are constants. We don't do this consistently in  
> the framework so far, but I'd like it to match stuff like  
> Event.KEY_ESC. I think the capitalization will also help distinguish  
> it from String#empty and Array#empty, as was mentioned elsewhere.  
> (Aside: I'm also in favor of renaming those methods to `isEmpty` for  
> 2.0.)
> What do people think about the capitalization?
> Cheers,
> Andrew
You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to