On Oct 15, 2009, at 4:22 AM, T.J. Crowder wrote:
> Hey Andrew,
> Aren't all functions constants, in that sense? Function.EMPTY isn't
> more or less constant than Element.extend.
Function.IDENTITY and Function.EMPTY are never called directly,
though. They're canonical functions.
Meh, if I'm the only one who thinks of them that way, I'll shut up.
But I want to hear from more people.
> -- T.J. ;-)
> On Oct 15, 1:08 am, Andrew Dupont <goo...@andrewdupont.net> wrote:
>> Weighing in again, decades after starting the thread.
>> First, I'm fine with calling it Function.IDENTITY instead of
>> On Sep 25, 2009, at 1:26 AM, T.J. Crowder wrote:
>>> Make sense. Shouldn't that be Function.empty and Function.k,
>>> to follow our naming rules? And perhaps Function.k should have a
>>> meaningful name.
>> I'm very much in favor of all-caps, or at least initial caps, to
>> indicate that these are constants. We don't do this consistently in
>> the framework so far, but I'd like it to match stuff like
>> Event.KEY_ESC. I think the capitalization will also help distinguish
>> it from String#empty and Array#empty, as was mentioned elsewhere.
>> (Aside: I'm also in favor of renaming those methods to `isEmpty` for
>> What do people think about the capitalization?
You received this message because you are subscribed to the Google Groups
"Prototype: Core" group.
To post to this group, send email to firstname.lastname@example.org
To unsubscribe from this group, send email to
For more options, visit this group at