Hi John,

This usually happens when you try to call a Prototype method on an
Element instance that hasn't been extended [passed through $()].  On
almost everything but IE, that's fine, but on IE you have to be sure
to pass the instance through $().

There's an article on this in the new unofficial Prototype &
script.aculo.us wiki, in the Troubleshooting section:

If you give that a quick read and then look at your application code
that's calling into Prototype when the error occurs, you'll probably
see where the missing $() should go.

More about the general topic of extending elements here:

T.J. Crowder
tj / crowder software / com

On Oct 20, 11:57 pm, jschank <[EMAIL PROTECTED]> wrote:
> Hello,
> I'm using protoype.js in a rails application. The application works
> fine on Safari, FireFox (both windows and mac), however, when I load
> my app in IE6, I get an "Error: Object doesn't support this property
> or method" pop up.
> When I choose to debug that in the script debugger, I see that the
> error is on the line which says element.fireEvent(event.eventType,
> event); which seems to be in a method with a fire: symbol at the
> beginning. (I'm not a javascript guru, I don't recognize that syntax)
> I've tried getting from the web site, and also tried getting
> the latest from github, and building it and deploying that. Still the
> problem persists.
> Does anyone have any idea of how to handle this?
> Thanks,
> John Schank
You received this message because you are subscribed to the Google Groups 
"Prototype & script.aculo.us" group.
To post to this group, send email to prototype-scriptaculous@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 

Reply via email to