Sorry I am just now getting back.  No I have not disappeared, just got busy.

So I tried the recommendations below, and I have not come to a resolution. I did not see an error in the log file for USB. I am not sure what to do next. I have considered just trying to load a different linux distribution or reloading Ubuntu, but I am not ready to do that yet.

Also, I know I will probably catch flak for this question, but is it possible to load the dev environment in Windows?

Jason


P.S.  I can not be there tonight.  Still a little busy.

Quoting ja...@cecs.pdx.edu:

Thanks all for recommendations. I will take a look this week. Also, I will not be there this Tuesday.

Later,
Jason

Quoting Kenny <ke...@romhat.net>:

apt-cache show openocd on my 12.04 system shows support for "USB FT2232
based dongles" including the "Olimex ARM-USB-OCD".

Jason, do you get any errors in /var/log/syslog when you connect USB?
Have you checked the device file for permissions issues?  Maybe you need
to add yourself to the dialout group in order to access /dev/ttyUSB0.
If this is the case sudo adduser `whoami` dialout, then log out and log
back in.  Group membership and related permissions are inherited from
your existing login session.  (You can also su - `whoami` to freshen
permissions for a given shell.)

--
Kenny
-+---+++-++-++++--+------+-+-++--++--+-+-++--+++-++----+-++-+++---+----+--+----+


On Sat, 2013-03-16 at 20:44 -0700, Theo Hill wrote:
I'm pretty sure the issue is that openocd wasn't built with the
--enable-ft2232-libftdi configure flag. To fix you'll have to compile
it yourself.

Make sure you have libftdi-dev (sudo apt-get install libftdi-dev) and
download the openocd source code (Sourceforge link).
Once you have it extracted, run
./configure --enable-ft2232-libftdi
make
make install


On Sat, Mar 16, 2013 at 11:55 AM, <ja...@cecs.pdx.edu> wrote:
       All,

       I have been trying to setup the development environment for
       the Olimex board.  I am running into an error involving the
       openocd package that I have not found the solution to.
       The error is;
       Error: The specified debug interface was not found (ft2232)
       The following debug interfaces are available:
       Runtime
Error: /opt/psas/openocd/share/openocd/scripts/interface/olimex-arm-usb-ocd.cfg:7:
       in procedure 'script'
       at file "embedded:startup.tcl", line 58
       at file "olimex_stm32_e407.cfg", line 7
       in procedure 'interface' called at file
"/opt/psas/openocd/share/openocd/scripts/interface/olimex-arm-usb-ocd.cfg", line 7

       The OS is Ubuntu 12.04 on a Macbook with a Intel® Core?2 CPU
       T7200 @ 2.00GHz × 2

       I tried running the updates, reinstalling, etc.  Also, K had
       taken a look and not found anything.

       Has anyone else seen anything like this?  Right now I am
       considering trying another OS, perhaps Debian.  I admit I am
       not that knowledgeable about Linux, so I get bogged down
       easily.

       Thanks,
       Jason Peterson



       _______________________________________________
       psas-avionics mailing list
       psas-avionics@lists.psas.pdx.edu
       http://lists.psas.pdx.edu/mailman/listinfo/psas-avionics


_______________________________________________
psas-avionics mailing list
psas-avionics@lists.psas.pdx.edu
http://lists.psas.pdx.edu/mailman/listinfo/psas-avionics






_______________________________________________
psas-avionics mailing list
psas-avionics@lists.psas.pdx.edu
http://lists.psas.pdx.edu/mailman/listinfo/psas-avionics






_______________________________________________
psas-avionics mailing list
psas-avionics@lists.psas.pdx.edu
http://lists.psas.pdx.edu/mailman/listinfo/psas-avionics

Reply via email to