What a headache! It's all starting to feel a bit perl3-4-5-ish.

I don't think we should try to standardize on either version but
here is a suggestion, since several of us are using python for
PSAS stuff.

1) The future is now? Lose this for python3?
# from __future__ import division

2) Consider adding this(or similar) check at the top of a source file:

 import sys
 if sys.version_info < (3, 0):
     sys.stdout.write("Sorry, this application requires Python 3.x, not Python 
2.x\n")
     sys.exit(1)

or if you want to run 2.x change as appropriate.

Not advocating for any requirements, just something to think about
going forward.

 -K









_______________________________________________
psas-avionics mailing list
psas-avionics@lists.psas.pdx.edu
http://lists.psas.pdx.edu/mailman/listinfo/psas-avionics

Reply via email to