Segue o que o Fellipe me mandou, feito no Ubuntu. Eu trocaria a última
linha colocando automático no boot, mas vá lá, cada um faz como quer.

Localização HAUWEI MODEM
/dev/ttyUSB0

Localização GIANT MODEM
/dev/ttyACM0

1) Abra o arquivo wvdial
/etc/wvdial.conf

2) Adiciona as seguintes linhas no final do arquivo, observe as linhas
de localização do modem, esta configuração é para o modelo GIANT
MODEM(/dev/ttyACM0) caso seja HAUWEI MODEM(/dev/ttyUSB0).

[Dialer Claro]
Phone = *99***1#
Username = claro
Password = claro
Stupid Mode = 1
Dial Command = ATDT
Modem = /dev/ttyACM0
Baud = 921600
Init2 = ATZ
Init3 = ATE0V1&D2&C1S0=0+IFC=2,2
ISDN = 0
Modem Type = Analog Modem
Init5 =AT+CGDCONT=1,"IP","claro.com.br"

3) Apos tudo configurado feche o arquivo e abra um terminal.

4) Digite o seguinte comando no terminal e estara conectado.

wvdial Claro

2008/4/10, Ada Lemos <[EMAIL PROTECTED]>:
> É isso ai gente,
> O  Marcello, nosso Harry Portter mais bonito e mágico, está me dando uma
> grande mão,
> me fazendo um favor daqueles.
> Quem puder ajudar, vc Pablo com seu amigo, vai ser demais
> e ficará resgistrado para quem quiser usar.
>  quero e preciso muito levar o meu note já arrumado pro FISL
> e com alguns experimentos feitos.
> Muitíssimo obrigada
> e merci a todos que já deram o seu alô com dicas.
> Abs,
> Ada
>
> Em 10/04/08, Marcello Bontempo Salgueiro <[EMAIL PROTECTED]>
> escreveu:
> > Salve glaera ajuda com o claro3g Giant D301
> > tentei usar varios tutos que encontrei no pastos google, mas nenhum
> funciono...
> > fui pegando um tuto com outro e juntei e fiz um conf para conectar mas
> mesmo assim nao consigo de forma alguma...
> > desta maneira resolvi mandar o erro de log e as configuracoes... se alguem
> poder me ajudar com a configuracao do PPPD
> > pois eu nao sei muito tenho que estudar e to meio sem tempo... e como
> estou fazendo um favor a nossa Ada Lemos...
> > se alguem poder ajudar ou opinar sera bem vindo!!! =)
> > segue as configuracoes e erro embaixo:
> >
> >
> > A configuracao padrao:
> >
> > ---- A configuracao padrao que o gnome-ppp escreve no .wvdial.conf do
> usuario:
> >
> > [Dialer Defaults]
> > Modem = /dev/ttyACM0
> > ISDN = off
> > Modem Type = USB Modem
> > Baud = 460800
> > Init = ATX3
> > Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
> > Init3 =
> > Init4 =
> > Init5 =
> > Init6 =
> > Init7 =
> > Init8 =
> > Init9 =
> > Phone1 =
> > Phone2 =
> > Phone3 =
> > Phone4 =
> > Dial Prefix =
> > Dial Attempts = 1
> > Dial Command = ATM1L3DT
> > Ask Password = off
> > Password = claro
> > Username = claro
> > Auto Reconnect = off
> > Abort on Busy = off
> > Carrier Check = on
> > Check Def Route = on
> > Abort on No Dialtone = on
> > Stupid Mode = off
> > Idle Seconds = 0
> > Auto DNS = on
> > ;Minimize = on
> > ;Dock = off
> > ;Do NOT edit this file by hand!
> >
> > ----- /etc/ppp/options(conf do pppd padrao)
> > asyncmap 0
> > noauth
> > crtscts
> > lock
> > hide-password
> > modem
> > debug
> > proxyarp
> > lcp-echo-interval 30
> > lcp-echo-failure 4
> > noipx
> >
> > ------ o log de erro  com os arquivos padrao da nao conexao:
> >
> > Apr 10 13:46:11 ada-laptop pppd[6160]: pppd 2.4.4 started by root, uid 0
> > Apr 10 13:46:11 ada-laptop pppd[6160]: Using interface ppp0
> > Apr 10 13:46:11 ada-laptop pppd[6160]: Connect: ppp0 <--> /dev/ttyACM0
> > Apr 10 13:46:11 ada-laptop pppd[6160]: CHAP authentication succeeded:
> Congratulations!
> > Apr 10 13:46:11 ada-laptop pppd[6160]: CHAP authentication succeeded
> > Apr 10 13:46:41 ada-laptop pppd[6160]: IPCP: timeout sending
> Config-Requests
> > Apr 10 13:46:41 ada-laptop pppd[6160]: Connection terminated.
> > Apr 10 13:46:41 ada-laptop pppd[6160]: Exit.
> >
> >
> >
> -----------------------------------------------------------------------------------------------------
> >
> > A configuracao que fiz olhando outros tutos:
> >
> > /etc/ppp/options
> >
> > asyncmap 0
> > noauth
> > crtscts
> > lock
> > hide-password
> > modem
> > noipdefault
> > passive
> > -vj
> > debug
> > ipcp-accept-local
> > ipcp-accept-remote
> > noipx
> > idle 7200
> > defaultroute
> > user claro
> > password claro
> > usepeerdns
> > nopcomp
> > nobsdcomp
> > nodeflate
> > connect "/usr/sbin/chat -v -f /etc/ppp/claro
> >
> > --- o arquivo /etc/ppp/claro
> >
> > ABORT BUSY
> > ABORT ERROR
> > REPORT CONNECT
> > TIMEOUT 120
> > "" "ATZ"
> > OK "AT+CPIN?"( verifica se precisa do ID do PIN)
> > OK 'AT+CPIN="3636"' (envia o pin)
> > TIMEOUT 60
> > OK "AT+COPS?" (verifica quem monitora)
> > OK "AT_OPSYS=3" (usa conctividade 3g)
> > OK 'AT+CGDCONT=1,"IP","claro.com.br"
> > SAY " A LIGAR ...."
> > TIMEOUT 90
> > TIMEOUT 40
> > CONNECT c
> >
> > ------ o log de erro com os confs montados
> >
> > Apr 10 14:05:20 ada-laptop pppd[6787]: pppd 2.4.4 started by root, uid 0
> > Apr 10 14:05:20 ada-laptop chat[6789]: abort on (BUSY)
> > Apr 10 14:05:20 ada-laptop chat[6789]: abort on (ERROR)
> > Apr 10 14:05:20 ada-laptop chat[6789]: report (CONNECT)
> > Apr 10 14:05:20 ada-laptop chat[6789]: timeout set to 120 seconds
> > Apr 10 14:05:20 ada-laptop chat[6789]: send (ATZ^M)
> > Apr 10 14:05:20 ada-laptop chat[6789]: expect (OK)
> > Apr 10 14:05:47 ada-laptop chat[6789]: %}(}"}'}"}"}&} } } } }%}&}$AUS:Q~^M
> > Apr 10 14:05:47 ada-laptop chat[6789]: NO CARRIER^M
> > Apr 10 14:07:20 ada-laptop chat[6789]: alarm
> > Apr 10 14:07:20 ada-laptop chat[6789]: Failed
> > Apr 10 14:07:20 ada-laptop pppd[6787]: Exit.
> >
> >
> > bom espero que isso ajude o pessoal e a nos tambem ada! =D
> > bjos
> >
> >
> >
> >
> > --
> > Powered by Outblaze
> >
>
>
> _______________________________________________
>  PSL-Brasil mailing list
>  PSL-Brasil@listas.softwarelivre.org
> http://listas.softwarelivre.org/mailman/listinfo/psl-brasil
>  Regras da lista:
> http://twiki.softwarelivre.org/bin/view/PSLBrasil/RegrasDaListaPSLBrasil
>
_______________________________________________
PSL-Brasil mailing list
PSL-Brasil@listas.softwarelivre.org
http://listas.softwarelivre.org/mailman/listinfo/psl-brasil
Regras da lista:
http://twiki.softwarelivre.org/bin/view/PSLBrasil/RegrasDaListaPSLBrasil

Responder a