Hmm, this sounds like an Eclipse bug tickled by Ptolemy adjusting
setting up the ptII/.classpath file.

I've seen stack traces inside eclipse 2.1.2.  Rather than
reinstalling, what I usually what I ended up doing was removing my
eclipse/workspace directory and trying various things.

You could try removing ptII/.classpath and seeing if the setup
completes.  That worked for me.

I was able to build after hacking adding the following to
   <classpathentry excluding="cm/" kind="src" path="ptolemy/copernicus/c/test"/>

and I had to add 
to the list of excluded files.

At one point, the Java build path window came up and I had
to remove jmf.jar and sound.jar

I later removed the jxta jar files because they had this
bogus ${PTII} inside of them.  I'll fix configure momentarily.
This bug occurred because our devel tree contains the jxta jar files,
but we don't ship these jar files.
To remove the jxta jar files, right click on the ptII project, select
Properties -> Java Build Path -> Libraries

You may later want to exclude ptolemy/moml/jxta from the build.

Below is a copy of the that worked for me: 
<?xml version="1.0" encoding="UTF-8"?>
    <classpathentry excluding="cm/" kind="src" path="ptolemy/copernicus/c/test"/>
         kind="src" path=""/>
    <classpathentry kind="con" path="org.eclipse.jdt.launching.JRE_CONTAINER"/>
    <classpathentry kind="output" path=""/>

I'll add a note to the website about this


    Thanks for your help,  I also tried the method described but I can not
    get the project compiled, here is what I tried :
    tar xfz ptII3.0.2.src.tar.gz
    mv ptII3.0.2 ptII
    export PTII="/home/franck/bin/my_PTII/ptII"
    cd $PTII
    cd ~/bin/my_PTII
       File->New Project
       Project Name : ptII
       Directory    : /home/franck/bin/my_PTII
    -->> An error occured while creating the java project
         Reason  : invalid project description
     /home/franck/bin/my_PTII and /home/franck/bin/my_PTII/workspace overlap
    If I change the directory with : /home/franck/bin/my_PTII/ptII
    -->> An error occurred while creating the java project
         See error log for more details.
         (java.lang.NullPointerException in the .log of Eclipse !)
    I tried other thinks but I can only compile and run (make fast install)
    without Eclipse !
    On Mon, 2004-05-03 at 17:14, Christopher Hylands Brooks wrote:
    > With Eclipse, usually it is necessary to run configure so that the
    > .classpath file is properly set up.  An alternative is to set up the
    > project class path by hand.  Locally, our Eclipse users run configure,
    > so the by hand section of the doc could probably use some testing
    > and updating.
    > One issue is that Ptolemy II includes many packages that
    > use other external packages that might not be present, so setting the
    > classpath and excluding packages by hand can be time consuming.
    > -Christopher
    > --------
    >     Good morning,
    >     I'm a software designer in the Pasteur Institute (Paris) and I'm
    >     involved with a workflow definition and conception for sequence analy
    >     (mainly). Ptolemy II seems to correspond to the core functionalities 
    >     need and seems to be easy to customize (thanks to have made docs and 
    >     diagrams !)
    >     Unfortunatly I'm trying to make an eclipse project following the
    >     instructions described but without success.
    >     I'm now trying to install Ptolemy "by hand" following the chapter
    >     "Setting up for Ptolemy II By Hand" described in doc/coding/eclipse.h
    >     and I have these errors :
    >     1 - The project was not built since its classpath is incomplete. Cann
    >     find the class file for ptolemy.math.Complex. Fix the classpath then 
    >     rebuilding this project.
    >     2 - For the file /ptolemy/matlab/test/ : 
    >     This compilation unit indirectly references the missing type
    >     ptolemy.math.Complex (typically some required class file is referenci
    >     a type outside the classpath)
    >     (Weird because I can see ptolemy.math in Eclipse) 
    >     Can you say me if there is a mistake in the procedure described or I
    >     made something wrong.
    >     Thanks a lot !
    >     Regards
    >     Franck Valentin
    >     ---------------------------------------------------------------------
    >    -
    >     Posted to the ptolemy-hackers mailing list.  Please send administrati
    >     mail for this list to: [EMAIL PROTECTED]
    > --------
    > -------------------------------------------------------------------------
    > Posted to the ptolemy-hackers mailing list.  Please send administrative
    > mail for this list to: [EMAIL PROTECTED]
    Posted to the ptolemy-hackers mailing list.  Please send administrative
    mail for this list to: [EMAIL PROTECTED]

Posted to the ptolemy-hackers mailing list.  Please send administrative
mail for this list to: [EMAIL PROTECTED]

Reply via email to