Hello Michael,

thanks a lot for the tip!

It was the modules compression which was turned on ...

Best regards,

------ Originalnachricht ------
Von: "Michael Olbrich" <m.olbr...@pengutronix.de>
An: ptxdist@pengutronix.de
Gesendet: 22.11.2017 14:14:39
Betreff: Re: [ptxdist] Empty modules.dep after kernel update


On Wed, Nov 22, 2017 at 12:27:28PM +0000, Matthias Klein wrote:
I am working on a kernel update from 4.4 to 4.14 in our ptxdist 2016.04
 based BSP.

 The kernel builds fine, but the modules.dep file is zero bytes long.
 I updated libkmod.make from version 22 to 24, but that did not help.

When I run the depmod from sysroot-host/sbin/ by hand it finds no symbols:

 ./depmod -a -n -b ~/bsp/platform-xxx/root 4.14.1-00003-gb5f7a9a47e0b
 # Aliases extracted from modules themselves.
 # Soft dependencies extracted from modules themselves.
 # Aliases for symbols, used by symbol_request().

If I run the same with the old 4.4 path I get a lot of symbols / output
 ./depmod -a -n -b ~/bsp/platform-xxx/root 4.4.79

 Does anyone have an idea what could be wrong, or what I can check?

Does it work with 'depmod' from your host system? Maybe you enabled module
compression fo 4.14? That's currently disabled in host-libkmod.


Pengutronix e.K. | | Industrial Linux Solutions | http://www.pengutronix.de/ | Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 | Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |

ptxdist mailing list

ptxdist mailing list

Reply via email to