Please step into my office, and I'll remove you :-)
Or look at the mail headers and take appropriate action: List-Unsubscribe: <http://groups.google.com/group/puppet-users/subscribe?hl=en_US>, <mailto:[email protected]> Regards, Martijn. On 25-01-11 07:48, [email protected] wrote: > > > -------------------------------------------------------------------------- > *From:* [email protected] > [mailto:[email protected]] *On Behalf Of > *[email protected] > *Sent:* Monday, January 24, 2011 1:00 PM > *To:* Abridged Recipients > *Subject:* [Puppet Users] Abridged summary of > [email protected] - 45 Messages in 9 Topics > > Today's Topic Summary > > Group: http://groups.google.com/group/puppet-users/topics > > * scheduler problem? <#group_thread_0> [1 Update] > * Do we need a new name for "--test"? <#group_thread_1> [34 Updates] > * mcollective for rhel 4 <#group_thread_2> [2 Updates] > * Puppet dashboard don't show current day <#group_thread_3> [2 > Updates] > * Behavior of local modules and their included facts > <#group_thread_4> [1 Update] > * problems with dependencies <#group_thread_5> [2 Updates] > * high 500 error rate on file metadata operations > <#group_thread_6> [1 Update] > * PSA: Please use <pre> tags when reporting bugs. > <#group_thread_7> [1 Update] > * another 2.6 question... stages <#group_thread_8> [1 Update] > > Topic: scheduler problem? > <http://groups.google.com/group/puppet-users/t/e00eda15de69b533> > > Antony Mayi <[email protected]> Jan 24 11:29AM ^ <#digest_top> > > Hi Nan, > > thanks. I have removed the schedule (re)definition but it does > still the same - > the tidy is called on every run (every 30 minutes). the > state.yaml after a > typical run has following more... > <http://groups.google.com/group/puppet-users/msg/7199a3f934647c02> > > Topic: Do we need a new name for "--test"? > <http://groups.google.com/group/puppet-users/t/fbe7bcfe04b5f657> > > Nigel Kersten <[email protected]> Jan 23 01:33PM -0800 ^ > <#digest_top> > > https://projects.puppetlabs.com/issues/2476 > > This does seem to confuse a fair few new users. > > What would be a better name for "--test"? > more... > <http://groups.google.com/group/puppet-users/msg/d3dd3cbe311368e8> > > Adam Nielsen <[email protected]> Jan 24 07:50AM +1000 ^ > <#digest_top> > > > https://projects.puppetlabs.com/issues/2476 > > > This does seem to confuse a fair few new users. > > > What would be a better name for "--test"? > > Using Gentoo's emerge as an example, how about more... > <http://groups.google.com/group/puppet-users/msg/4f4c6c8b58c491c2> > > Nigel Kersten <[email protected]> Jan 23 02:15PM -0800 ^ > <#digest_top> > > > >> This does seem to confuse a fair few new users. > > >> What would be a better name for "--test"? > > > Using Gentoo's emerge as an example, how about --oneshot? > > It's more than that though. > more... > <http://groups.google.com/group/puppet-users/msg/69a330193ef7d96d> > > Denmat <[email protected]> Jan 24 09:35AM +1100 ^ <#digest_top> > > I was thinking '--update' as that is what it does but then that > doesn't describe the '--one-time' nature of it explicitly. > > I always felt funny updating hosts with 'test' though :) > > Hard one. > more... > <http://groups.google.com/group/puppet-users/msg/1313878342cdbaa7> > > Patrick <[email protected]> Jan 23 02:44PM -0800 ^ <#digest_top> > > On Jan 23, 2011, at 1:50 PM, Adam Nielsen wrote: > > > >> This does seem to confuse a fair few new users. > > >> What would be a better name for "--test"? > > > Using Gentoo's emerge as an example, how more... > <http://groups.google.com/group/puppet-users/msg/32700f78acf03e7> > > Daniel Pittman <[email protected]> Jan 23 03:35PM -0800 ^ > <#digest_top> > > My inclination is to say that "ontime" or "verbose" have stolen > the name for > another concept; perhaps "interactive" covers the standard > use-case well > enough? > > Daniel > > >>> What would be a better more... > <http://groups.google.com/group/puppet-users/msg/ba3086cb22134102> > > Dan Bode <[email protected]> Jan 23 03:38PM -0800 ^ <#digest_top> > > > > >>> https://projects.puppetlabs.com/issues/2476 > > > >>> This does seem to confuse a fair few new users. > > > >>> What would be a better name for "--test"? > > maybe we could keep --test and add more... > <http://groups.google.com/group/puppet-users/msg/76601ceef12222cd> > > Nigel Kersten <[email protected]> Jan 23 03:48PM -0800 ^ > <#digest_top> > > > >> >>> This does seem to confuse a fair few new users. > > >> >>> What would be a better name for "--test"? > > > maybe we could keep --test and add --noop to the list of > options in sets. > more... > <http://groups.google.com/group/puppet-users/msg/244d60976141b243> > > James Louis <[email protected]> Jan 23 06:02PM -0600 ^ > <#digest_top> > > and what is the current functionality for the --test option? > > > -- > “Twenty years from now you will be more disappointed by the > things that you > didn’t do than by the ones you did do. more... > <http://groups.google.com/group/puppet-users/msg/e8eae94aa11e26d8> > > Patrick <[email protected]> Jan 23 04:42PM -0800 ^ <#digest_top> > > On Jan 23, 2011, at 4:02 PM, James Louis wrote: > > > and what is the current functionality for the --test option? > > To quote Nigel: > > --onetime > --no-daemonize > --ignorecache > --verbose more... > <http://groups.google.com/group/puppet-users/msg/4b97b5f36bd44de0> > > James Louis <[email protected]> Jan 23 06:47PM -0600 ^ > <#digest_top> > > that tells what options are applied when --test is used but > doesn't explain > the functionality of --test (i.e. --test is an option to enable > the puppet > agent to test it's connection to the puppet more... > <http://groups.google.com/group/puppet-users/msg/908f0f7f43eb6443> > > Stefan Schulte <[email protected]> Jan 24 01:49AM > +0100 ^ <#digest_top> > > On Sun, Jan 23, 2011 at 03:48:16PM -0800, Nigel Kersten wrote: > > some sympathy for that position, but before we can get there, > we need > > to have a name for the existing functionality that I don't > more... > <http://groups.google.com/group/puppet-users/msg/ff53e41916079ae3> > > Patrick <[email protected]> Jan 23 04:50PM -0800 ^ <#digest_top> > > On Jan 23, 2011, at 4:47 PM, James Louis wrote: > > > that tells what options are applied when --test is used but > doesn't explain the functionality of --test (i.e. --test is an > option to enable the more... > <http://groups.google.com/group/puppet-users/msg/716d2ac4f39c3907> > > James Louis <[email protected]> Jan 23 06:53PM -0600 ^ > <#digest_top> > > exactly. to what purpose? > > > -- > “Twenty years from now you will be more disappointed by the > things that you > didn’t do than by the ones you did do. So throw off the > bowlines. Sail away more... > <http://groups.google.com/group/puppet-users/msg/2db6dda09757cd4f> > > Nigel Kersten <[email protected]> Jan 23 05:22PM -0800 ^ > <#digest_top> > > > exactly. to what purpose? > > To trigger an immediate run on a client with the common options used > when testing a real run, not a noop run. > > If there was a clear word that described this more... > <http://groups.google.com/group/puppet-users/msg/f353c7fb94ce4412> > > James Louis <[email protected]> Jan 23 07:34PM -0600 ^ > <#digest_top> > > so the actual changes take place, if any, during a test vs a > noop which does > not let the actual changes take place. So this would be used > primarily for > configuration testing? Or perhaps for more... > <http://groups.google.com/group/puppet-users/msg/6b548d99953bbd1f> > > Nigel Kersten <[email protected]> Jan 23 05:51PM -0800 ^ > <#digest_top> > > > so the actual changes take place, if any, during a test vs a > noop which does > > not let the actual changes take place. So this would be used > primarily for > > configuration testing? Or perhaps for more... > <http://groups.google.com/group/puppet-users/msg/3994d632374b04de> > > eshamow <[email protected]> Jan 23 05:58PM -0800 ^ <#digest_top> > > I can tell you that for me, and for my group, it's a halfway step > between reloading Puppet and watching the logs, and a full > --debug -- > no-daemonize run. > > So for instance, when they're more... > <http://groups.google.com/group/puppet-users/msg/ae6e3bb895a0258c> > > James Louis <[email protected]> Jan 23 08:16PM -0600 ^ > <#digest_top> > > so the purpose of having a noop is to run the same test but to > not actually > make any changes. do we get the same debug messages, etc? > > > -- > “Twenty years from now you will be more disappointed more... > <http://groups.google.com/group/puppet-users/msg/80c79a8f81fa29d> > > Patrick <[email protected]> Jan 23 07:23PM -0800 ^ <#digest_top> > > No, because sometimes making the changes causes the error. > > For instance, if you are using a File resource to create a file > in a read-only file-system (which isn't possible) the resource > will tell more... > <http://groups.google.com/group/puppet-users/msg/d1b35186370e1f99> > > Patrick <[email protected]> Jan 23 07:26PM -0800 ^ <#digest_top> > > On Jan 23, 2011, at 4:53 PM, James Louis wrote: > > > > > that tells what options are applied when --test is used but > doesn't explain the functionality of --test (i.e. --test is an > option to enable the more... > <http://groups.google.com/group/puppet-users/msg/6f0ed82ca21de926> > > Patrick <[email protected]> Jan 23 07:27PM -0800 ^ <#digest_top> > > On Jan 23, 2011, at 5:58 PM, eshamow wrote: > > > > It might be wise to consider combining a bunch of similar options > > (verbose, test, debug, etc) into a "verbose" with levels of > output -- more... > <http://groups.google.com/group/puppet-users/msg/b53be26b1d611377> > > Patrick <[email protected]> Jan 23 07:30PM -0800 ^ <#digest_top> > > On Jan 23, 2011, at 4:49 PM, Stefan Schulte wrote: > > > (maybe it does so already). We could then say --test --no-noop > to match > > current behaviour. > > > -Stefan > > > I think this is a really bad more... > <http://groups.google.com/group/puppet-users/msg/c40dcb1e2545c4dc> > > Nigel Kersten <[email protected]> Jan 23 07:38PM -0800 ^ > <#digest_top> > > > >> -Stefan > > > I think this is a really bad idea because I really think > Puppet has broken a lot of things recently and people use --test > in automatic scripts. > > > This is really almost always an more... > <http://groups.google.com/group/puppet-users/msg/8ddaf1872f18c305> > > Jesse Reynolds <[email protected]> Jan 23 10:27PM -0800 ^ > <#digest_top> > > --manual > > ? > more... > <http://groups.google.com/group/puppet-users/msg/c33ee19af8a85b7a> > > Stig Sandbeck Mathisen <[email protected]> Jan 24 07:56AM +0100 ^ > <#digest_top> > > > > I know some people use it whenever they want "--verbose > --no-daemonize > > --onetime". > > This is common use of the puppet agent at my site. > > -- > Stig Sandbeck Mathisen > more... > <http://groups.google.com/group/puppet-users/msg/22903c06821f6248> > > Stig Sandbeck Mathisen <[email protected]> Jan 24 08:36AM +0100 ^ > <#digest_top> > > > > --manual > > Looks better than --interactive, since I don't assume it will start > asking me questions. :) > > -- > Stig Sandbeck Mathisen > Oooo, shiny! > more... > <http://groups.google.com/group/puppet-users/msg/5485e90e6f2b4296> > > Daniel Pittman <[email protected]> Jan 24 12:13AM -0800 ^ > <#digest_top> > > > >> --manual > > > Looks better than --interactive, since I don't assume it will > start > > asking me questions. :) > > I like it too. > Daniel > -- > ⎋ Puppet Labs Developer – more... > <http://groups.google.com/group/puppet-users/msg/f3c2d0ba394e2fff> > > DEGREMONT Aurelien <[email protected]> Jan 24 09:27AM > +0100 ^ <#digest_top> > > Nigel Kersten a écrit : > > when testing a real run, not a noop run. > > > If there was a clear word that described this functionality, we > > probably wouldn't be having this discussion. > more... > <http://groups.google.com/group/puppet-users/msg/559a57524f22842b> > > "Carles Amigó" <[email protected]> Jan 24 11:38AM +0100 > ^ <#digest_top> > > +1 > > El 24/01/2011 9:13, Daniel Pittman escribió: > >> asking me questions. :) > > > I like it too. > > Daniel > > -- > Carles Amigó > Linux System Administrator > [email protected] > more... > <http://groups.google.com/group/puppet-users/msg/4a0be4f51eb4066e> > > Adam Nielsen <[email protected]> Jan 24 09:00PM +1000 ^ > <#digest_top> > > > --verbose > > --no-usecacheonfailure > > > and I think I'm missing some newer additions too. > > Hmm that's true, and it is similar to --onetime. How about > --explain? The > end result is that you get more... > <http://groups.google.com/group/puppet-users/msg/192cc6d6dafb738> > > Jonathan Gazeley <[email protected]> Jan 24 11:01AM > ^ <#digest_top> > > On 24/01/11 11:00, Adam Nielsen wrote: > > added to do the same with no-op as well. > > > Cheers, > > Adam. > > How about simply --once ? Nice and quick to type. > > Jonathan > > -- more... > <http://groups.google.com/group/puppet-users/msg/19f7280b37790b73> > > Adam Nielsen <[email protected]> Jan 24 09:11PM +1000 ^ > <#digest_top> > > > >> Hmm that's true, and it is similar to --onetime. How about > --explain? > >> The end result is that you get a detailed explanation of what > is happening. > > > How about simply --once ? Nice and quick more... > <http://groups.google.com/group/puppet-users/msg/c19d135db7d8c956> > > Thorsten Biel <[email protected]> Jan 24 12:22PM +0100 ^ > <#digest_top> > > On Jan 24, 2011, at 12:00, Adam Nielsen wrote: > > > >> and I think I'm missing some newer additions too. > > > Hmm that's true, and it is similar to --onetime. How about > --explain? The end result is more... > <http://groups.google.com/group/puppet-users/msg/dac514ef05060f52> > > Topic: mcollective for rhel 4 > <http://groups.google.com/group/puppet-users/t/4c6bbbe891d71082> > > eshamow <[email protected]> Jan 23 05:23PM -0800 ^ <#digest_top> > > The Fedora 13 SRPMs backport pretty easily, and you get the > advantage > of Ruby 1.8.6. > > -Eric > > more... > <http://groups.google.com/group/puppet-users/msg/e523b679921a0f35> > > Ohad Levy <[email protected]> Jan 24 11:08AM +0200 ^ <#digest_top> > > > > The Fedora 13 SRPMs backport pretty easily, and you get the > advantage > > of Ruby 1.8.6. > > > -Eric > > Sure, but for those who don't want to replace/break the > internals of ruby on > rhel4... :) > > more... > <http://groups.google.com/group/puppet-users/msg/540eca7921dacb0f> > > Topic: Puppet dashboard don't show current day > <http://groups.google.com/group/puppet-users/t/6d9c8dda8feda0ff> > > Nicolas Aizier <[email protected]> Jan 23 05:43PM > -0800 ^ <#digest_top> > > I made some more research on this problem and found another one. I > think it's linked. > > The 30th day of puppet (the one the more on the left side in puppet- > dashboard) is slowly decrasing in term more... > <http://groups.google.com/group/puppet-users/msg/20844acbfb20284e> > > Nicolas Aizier <[email protected]> Jan 23 09:48PM > -0800 ^ <#digest_top> > > Raised bug #5983 about those points. > > On Jan 24, 11:43 am, Nicolas Aizier <[email protected]> > wrote: > more... > <http://groups.google.com/group/puppet-users/msg/2de3d92e0352da4c> > > Topic: Behavior of local modules and their included facts > <http://groups.google.com/group/puppet-users/t/de0c9b342bd7007> > > Nigel Kersten <[email protected]> Jan 23 02:18PM -0800 ^ > <#digest_top> > > On Fri, Jan 21, 2011 at 9:40 AM, Nick Fagerlund > > issues/4180). This was never fixed in 0.25.x, right? Should we > re-open > > or file a new ticket? > > > (Also, should this bug be mentioned in the more... > <http://groups.google.com/group/puppet-users/msg/c22a49d9fed12797> > > Topic: problems with dependencies > <http://groups.google.com/group/puppet-users/t/da35198378c28b21> > > "russell.fulton" <[email protected]> Jan 23 01:17PM -0800 > ^ <#digest_top> > > Thanks John... using before worked. > > I'm new to puppet and I found the independent resource chaining > stuff > before I found 'before' which I note is not mentioned anywhere > in the > docs for exec. > more... > <http://groups.google.com/group/puppet-users/msg/641f0980d2171af> > > Nigel Kersten <[email protected]> Jan 23 02:17PM -0800 ^ > <#digest_top> > > On Sun, Jan 23, 2011 at 1:17 PM, russell.fulton > > docs for exec. > > > is this a doc bug or is it a generic option available with all > > resources? > > It's the latter Russell. You can find them all in more... > <http://groups.google.com/group/puppet-users/msg/4b7ca4d915cfd26c> > > Topic: high 500 error rate on file metadata operations > <http://groups.google.com/group/puppet-users/t/8f78a3f1d71afa2> > > Daniel Pittman <[email protected]> Jan 23 01:59PM -0800 ^ > <#digest_top> > > > logging of puppet errors. I've done some analysis of the logs > that I > > have and found that the majority of the 500s (~83%) received > by our > > Ubuntu clients are on file metadata operations: > more... > <http://groups.google.com/group/puppet-users/msg/3554c5d0fc1cddf9> > > Topic: PSA: Please use <pre> tags when reporting bugs. > <http://groups.google.com/group/puppet-users/t/5e4c1ffd8b340533> > > Nigel Kersten <[email protected]> Jan 23 01:48PM -0800 ^ > <#digest_top> > > It's particularly difficult to understand what's going on with a > given > bug report when the log/manifest/terminal output is all being > mis-interpreted as Markdown text. > > We'll definitely try and more... > <http://groups.google.com/group/puppet-users/msg/acc9991164c5415e> > > Topic: another 2.6 question... stages > <http://groups.google.com/group/puppet-users/t/2aa399bda4e013fb> > > Daniel Pittman <[email protected]> Jan 23 09:49AM -0800 ^ > <#digest_top> > > > } > > > Is it safe to assume that "foo" will always be managed during > the preamble > > stage regardless of other definitions? > > Puppet will treat a dependency that would violate that > expectation as more... > <http://groups.google.com/group/puppet-users/msg/4c4b9441463c6826> > > -- > You received this message because you are subscribed to the Google > Groups "Puppet Users" group. > To post to this group, send email to [email protected]. > To unsubscribe from this group, send email to > [email protected]. > For more options, visit this group at > http://groups.google.com/group/puppet-users?hl=en. > > -- > You received this message because you are subscribed to the Google Groups > "Puppet Users" group. > To post to this group, send email to [email protected]. > To unsubscribe from this group, send email to > [email protected]. > For more options, visit this group at > http://groups.google.com/group/puppet-users?hl=en. -- You received this message because you are subscribed to the Google Groups "Puppet Users" group. To post to this group, send email to [email protected]. To unsubscribe from this group, send email to [email protected]. For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
