On 08.07.2013 20:06, Nan Liu wrote:
    This is definitely something we want to do and need to do.  I've
    been a little hesitant to wade down into the whole "these are the
    specific parameter names we want to use" and building out a huge set
    of guidelines, but I do have a straightforward question for the list
    along these lines:

    We're refactoring the ntp module to try and be a little bit of a
    better design rather than one giant class.  We've been having some
    discussions in the PR about the right way to name the following options:

    manage_service
    ensure_package
    package_enable

    I was leaning towards:

    ensure_package
    enable_package
    ensure_service.

    But it's been proposed that:

    service_ensure
    package_enable


  I would agree with resource_attributes order instead of the other way
around. It also makes sense because you can just introspect the class
parameters with .sort and everything is in an easy to find order.

Indeed, the grouping by lexical order is one of the main arguments for that. Also it mirrors the order in which the words are written in the manifest:

  class X { package { Y: ensure => present
    =>
  $X::[package_][Y_]ensure == present

Regards, David

--
You received this message because you are subscribed to the Google Groups "Puppet 
Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to puppet-users+unsubscr...@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to