applied to master

On Wed, Jul 12, 2017 at 07:34:51AM +0200, Thomas Lamprecht wrote:
> If we get an VM machine older than 2.9 we use the old selection
> expression for the VGA type. This allows to live migrate VMs to PVE
> 5.0 from beta 1 and PVE 4.4 again.
> 
> Signed-off-by: Thomas Lamprecht <t.lampre...@proxmox.com>
> ---
> 
> changes v1 -> v2:
> * renamed from "add workaround for pve 4.4 to 5.0 live migration"
> * move code handling this to PVE 5.0, as this is how we do it normally
> * obtain from touching the config, this is to much of a hack
> 
>  PVE/QemuServer.pm | 6 +++++-
>  1 file changed, 5 insertions(+), 1 deletion(-)
> 
> diff --git a/PVE/QemuServer.pm b/PVE/QemuServer.pm
> index 79a65ee..01753d9 100644
> --- a/PVE/QemuServer.pm
> +++ b/PVE/QemuServer.pm
> @@ -2925,7 +2925,11 @@ sub config_to_command {
>      $vga = 'qxl' if $qxlnum;
>  
>      if (!$vga) {
> -     $vga = (!$winversion || $winversion >= 6) ? 'std' : 'cirrus';
> +     if (qemu_machine_feature_enabled($machine_type, $kvmver, 2, 9)) {
> +         $vga = (!$winversion || $winversion >= 6) ? 'std' : 'cirrus';
> +     } else {
> +         $vga = ($winversion >= 6) ? 'std' : 'cirrus';
> +     }
>      }
>  
>      # enable absolute mouse coordinates (needed by vnc)
> -- 
> 2.11.0

_______________________________________________
pve-devel mailing list
pve-devel@pve.proxmox.com
https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel

Reply via email to