On 2/13/18 4:47 PM, Dominik Csapak wrote:
> between qemu 2.9 and 2.11 there were added some new commands,
> the guest agent inside the vm has to support these
> 

What happens if it does not? Probably way cheaper to just let it
error out, than probing the qga version before, I guess?

> Signed-off-by: Dominik Csapak <d.csa...@proxmox.com>
> ---
>  PVE/API2/Qemu/Agent.pm | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
> 
> diff --git a/PVE/API2/Qemu/Agent.pm b/PVE/API2/Qemu/Agent.pm
> index 24b44a9..40d9ff7 100644
> --- a/PVE/API2/Qemu/Agent.pm
> +++ b/PVE/API2/Qemu/Agent.pm
> @@ -28,6 +28,11 @@ my $guest_agent_commands = [
>      'suspend-ram',
>      'suspend-disk',
>      'shutdown',
> +    # added since qemu 2.9
> +    'get-host-name',
> +    'get-osinfo',
> +    'get-users',
> +    'get-timezone',
>      ];
>  
>  # properties for each command, optional
> @@ -57,6 +62,18 @@ my $ga_cmd_properties =  {
>      'info' => {
>       method => 'GET',
>      },
> +    'get-host-name' => {
> +     method => 'GET',
> +    },
> +    'get-osinfo' => {
> +     method => 'GET',
> +    },
> +    'get-users' => {
> +     method => 'GET',
> +    },
> +    'get-timezone' => {
> +     method => 'GET',
> +    },
>  };
>  
>  __PACKAGE__->register_method({
> 


_______________________________________________
pve-devel mailing list
pve-devel@pve.proxmox.com
https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel

Reply via email to