Changes since V1:
- split patch into smaller parts
- new helper $compute_param_mapping_hash()
- improve parameter names
- add some inline docs

Besides, functionality should be still the same.


Dietmar Maurer (6):
  introduce compute_param_mapping_hash helper
  rename $stringfilemap to $param_mapping_func
  rename $can_str_param_fmap to $param_mapping_func
  rename $pwcallback to $read_password_func
  rename $can_read_pass to $read_password_func
  use better name for string_param_file_mapping (param_mapping).

 src/PVE/CLIHandler.pm  | 26 +++++++++--------
 src/PVE/RESTHandler.pm | 78 +++++++++++++++++++++++++++++++++++---------------
 2 files changed, 69 insertions(+), 35 deletions(-)

-- 
2.11.0

_______________________________________________
pve-devel mailing list
pve-devel@pve.proxmox.com
https://pve.proxmox.com/cgi-bin/mailman/listinfo/pve-devel

Reply via email to