a pve-kernel-4.15 meta package depending on a preview build based on
Ubuntu Bionic's 4.15 kernel is available on pvetest. it is provided as
opt-in package in order to catch potential regressions and hardware
incompatibilities early on, and allow testing on a wide range of systems
before the default kernel series gets switched over to 4.15 and support
for our 4.13 based kernel is phased out at some point in the future.

in order to try it out on your test systems, configure the pvetest
repository and run

 apt update
 apt install pve-kernel-4.15

the pve-kernel-4.15 meta package will keep the preview kernel updated,
just like the pve-kernel-4.13 meta package (recently pulled out of the
proxmox-ve package) does for the stable 4.13 based kernel.

also on pvetest, you will find a pve-headers-4.15 header meta package in
case you need them for third-party module building, a linux-tools-4.15
package with compatible perf, as well as an updated pve-firmware package
with the latest blobs.

notable changes besides the major kernel update include the removal of
out-of-tree Intel NIC modules, which are not (yet) compatible with 4.15
kernels. this removal be re-evaluated at some later point before the
final switch to 4.15 as new stable kernel in PVE 5.

there are no plans to support both 4.13 and 4.15 in the long term - once
the testing phase of 4.15 is over 4.15 will become the new default
kernel and 4.13 will receive no updates anymore.

happy testing and looking forward to feedback!

pve-user mailing list

Reply via email to