--- Begin Message ---
Apologies for replying to myself, but I have a litte more information.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Tuesday, May 12, 2020 1:12 PM, <leeste...@pm.me> wrote:

> Hi PVE-users,
> Lately, on a no-subscription Proxmox (that I update regularly since release 
> 6.0), I get the following error when changing the CPU limit of any 
> (unpriviliged) container:
> Parameter verification failed. (400)
> cpulimit: unable to hotplug cpulimit: unable to open file 
> '/sys/fs/cgroup/memory///lxc/115/ns/cpu.cfs_period_us'
> -   No such file or directory
>     /etc/pve/lxc/115.conf:
>     arch: amd64
>     console: 0
>     cpulimit: 1.5
>     hostname: vnc15
>     memory: 2048
>     #mp0: ...
>     net0: 
> name=eth0,bridge=vmbr0,firewall=1,gw=,hwaddr=52:54:56:17:02:15,ip=,type=veth
>     onboot: 1
>     ostype: debian
>     protection: 1
>     rootfs: qpool-zfs:subvol-115-disk-0,size=3G
>     swap: 128
>     unprivileged: 1
>     [pve:pending]
>     cpulimit: 1
>     Indeed, there are no cpu.* files in the directories of any of my 
> containers. Is there something wrong with my setup?
>     Maybe someone has run into the same problem or can tell me how to fix 
> this?

I just tested a fresh install of Proxmox VE 6.2 (in a VM of course) and I get 
the same error about not being able to hotplug cpulimit on a freshly installed 
(unprivileged) container (Debian 10). Why does Proxmox try to hotplug cpulimit 
if it is not possible?

I also tested Proxmox VE 6.0 and it does not give an error. However, there are 
no cpu.* files in /sys/.. so maybe it just does not try to hotplug it? Maybe it 
never worked but only recently gives an error? Or maybe it is a regression?

The work-around is to reboot the container, which is fine for me. I just want 
to inform you about this issue.

kind regards, Arjen

--- End Message ---
pve-user mailing list

Reply via email to