On Thursday, February 22, 2018 04:44:17 PM Daniel Kahn Gillmor wrote:
> On Wed 2018-02-21 15:11:42 -0800, Barry Warsaw wrote:
> > On Feb 19, 2018, at 19:12, Daniel Kahn Gillmor <d...@fifthhorseman.net> 
wrote:
> >> Is there any reason *not* to ask command-line tools that are
> >> python2-only to ship with a /usr/bin/python2 shebang line in debian and
> >> to explicitly declare a dependency on python2.7 instead of python?
> > 
> > I’m unfortunately not in a position to help much with this right now,
> > but I’d say if there’s someone motivate to make the appropriate
> > changes to the helpers, then no there’s no reason not to do this now.
> 
> I agree with Barry that fixing it in the helpers would be the right way
> to go.
> 
> Alas, I don't have the time to work on the helpers either, but as a
> proof that it works and no disaster is immediately apparent, i've gone
> ahead and fixed up getmail (which is python2-only) to use the python2
> shebang line, and has an explicit dependency on python2.7 instead of
> python.
> 
> Please take a look at getmail 5.5-3 if you're interested in what the
> package looks like.
> 
> If dh_python2 got updated to:
> 
>  A) force the python2 shebang line for any scripts installed in bin or
>     sbin, and
> 
>  B) to evaluate the ${python:Depends} substvar to python2.7 instead of
>     the current python:any (<< 2.8), python:any (>= 2.7.5-5~)
> 
> Then i'd be happy to revert the packaging changes to getmail and fall
> back to the dh defaults :)
> 
> I'm not immersed enough in dh-python to know how to make those changes
> myself right now, though.

As far as I know, /usr/bin/python will be retired the same time that python2.7 
is removed from Debian.  Even after python2.7 is removed from Debian, there 
will be users that build from source and use it for local scripts.  Pointing 
/usr/bin/python at a python3 version will only cause gratuitous harm to our 
users.  It is not going to happen while I'm one of the python/python3-defaults 
maintainers.

Given that, I don't see value added in swapping Depends python:any (<< 2.8), 
python:any (>= 2.7.5-5~) with Depends: python2.7.  Can you explain why you 
think this is better?  I don't see it.

Scott K

_______________________________________________
py3porters-devel mailing list
py3porters-devel@lists.alioth.debian.org
https://lists.alioth.debian.org/mailman/listinfo/py3porters-devel

Reply via email to