On 29/10/14 21:36, Greg Ewing wrote:
Lorenz Quack wrote:
* you cannot access the components x/y/z directly...
> use ... new accessor methods x()/y()/z()
Is this change really necessary? It will be a big backward
step for code readability.
There shouldn't be any reason you can't provide read-only
access using attribute notation.
Hi Greg,
necessary? No.
Actually the first version I had took exactly the approach you suggested
(read-only attributes).
I guess, using PyQt4 lately I followed their convention.
Also using methods makes it more explicit that the values are read-only.
But I agree that adding the parenthesis is more verbose.
Let me think about it (or get some more feedback), but I feel inclined to rule
in your favour :)
Cheers for the feedback,
Lorenz