Hi Daniel,

Thanks for your comments.

The key user interface classes are in "pygwidgets".  In the "pyghelpers" 
package, the Timers, the Scene Manager, the Scene base class, and the dialog 
box functions can be useful for building games.

Yes, I agree that the File I/O functions are not as important.  But I had 
already built these for my current intro course where I introduce the concepts 
of writing to and reading from a file, and decided to throw them in here as 
well.

As far as the naming convention is concerned, I've used camelCase for so many 
years, that it is second nature to me.  I've grown comfortable with it from 
using it in many other languages, and when I started doing Python, I 
immediately started using it here too.  As long as I'm consistent with my 
naming conventions, my students are happy.

Irv

> On Dec 26, 2018, at 2:41 PM, Daniel Foerster <pydsig...@gmail.com> wrote:
> 
> I haven't had a chance to run the demo programs, but I think providing a 
> basic UI toolkit is sound. I do have concerns about the functions like 
> openFileForReading. I don't think there's enough value in those 
> encapsulations to outweigh the cost of teaching a new user to Python 
> abstractions around basic concepts like filehanding and hindering the growth 
> of their understanding of the Real APIs, and you lose out on a perfect segue 
> into things like garbage collection and with-clauses.
> I also think that a library for students should help them learn to use 
> PEP8-compliant snake_case, but that's a lesser issue.

Reply via email to