I've hit this error as well and Googling turned up some potential issues 
with the way the Anaconda library is currently built.  If you do an "otool 
-L" on that dylib, you'll see it doesn't have @rpath in front of it.  Macs 
are very picky in how they chose to load a dylib and names and locations 
need to match exactly.

Do yourself a favor... I just went through hours and hours of trying to get 
the current Anaconda working well to no avail.  I tried MacPorts to no 
avail.  I made a VM and used homebrew and everything works perfectly 
without any hint of mucking with anything.  Yes, I needed to install SciPy 
and stuff manually, but pip handled the vast majority of it just fine.  The 
one exception was PyQt, which needed "brew install pyqt" and that was it.

Craig


On Monday, September 5, 2016 at 5:14:25 AM UTC-7, al...@vitallabs.co wrote:
>
> Hello,
>
> I'm trying to use pyinstaller to build an application on OSX. I'm in a 
> virtual environment created using conda. When I run pyinstall I get the 
> following error ...
>
> OSError: Python library not found: Python, .Python, libpython3.5.dylib
>
> Has anyone else encountered this error from a conda environment and is 
> there a workaround?
>
> Thanks!
> Alan
>

-- 
You received this message because you are subscribed to the Google Groups 
"PyInstaller" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to pyinstaller+unsubscr...@googlegroups.com.
To post to this group, send email to pyinstaller@googlegroups.com.
Visit this group at https://groups.google.com/group/pyinstaller.
For more options, visit https://groups.google.com/d/optout.

Reply via email to