Raymond Hettinger wrote: > >>> We could always rename raw_input() to input(). Just a thought. . . >>> >> >> D'oh. Guido already said he doesn't like that idea :) >> >> > > FWIW, I think it is a good idea. If there is a little 2.x vs 3.0 > confusion, so be it. The use of input() function is already somewhat > rare (both because of infrequent use cases and because of the stern > warnings about eval's security issues). It is better to bite the bullet > and move on than it would be to avoid the most obvious name. > > Raymond
Maybe "input" can be depreciated in 2.x with a messages to use eval(raw_input()) instead. That would limit some of the confusion. _______________________________________________ Python-3000 mailing list [email protected] http://mail.python.org/mailman/listinfo/python-3000 Unsubscribe: http://mail.python.org/mailman/options/python-3000/archive%40mail-archive.com
