Nick Coghlan added the comment:

As far as "path import finder" goes, it's no more wrong than "meta path finder" 
and "path entry finder". A "meta path finder" is a finder that gets installed 
on sys.meta_path, a "path entry finder" is one that finds loaders based on a 
specific path entry, and the "path import finders" finds loaders based on the 
full path import machinery (sys.path, __path__ attributes, sys.path_hooks, sys.
path_importer_cache").

As far as FileFinder goes, FilePathEntryFinder is an awful name. If we change 
the name at all (which I don't consider necessary, since FileFinder is just 
fine as a name for a finder that finds loaders for files), then more 
appropriate names would be FilesystemFinder or DirectoryFinder. I like the 
simplicity of FileFinder though and am -1 on changing it.

I'm far more comfortable with the idea of explaining that the qualifiers on the 
"finder" and "importer" terms may convey information regarding one or more of 
the kind of loaders being found (FileFinder, BuiltinImporter, FrozenImporter, 
zipimporter), the information sources that are being searched (BuiltinImporter, 
FrozenImporter, zipimporter, PathEntryFinder, PathImportFinder), or how the 
finders are themselves retrieved (PathEntryFinder, MetaPathFinder) than I am 
with trying to redefine the decade old unambiguous meaning of the "importer" 
term as something which is both a finder and a loader.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue15502>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to