Ezio Melotti added the comment:
I prefer ModuleNotFound. Its meaning is already clear enough, even without the
OTOH we now have FileNotFoundError, but all the other OSError subclasses have
In general I think the suffix is necessary when it's not already clear from the
name that we are dealing with an exception, otherwise it can be dropped.
Python tracker <rep...@bugs.python.org>
Python-bugs-list mailing list