Meador Inge added the comment: Personally I prefer using attributes instead of pragmas. The GCC manual recommends such as well. There are also other sources in Modules/* that use '__attribute__ ((visibility ("hidden")))'. Namely ctypes and zlib.
I can understand that it is more work, but I find something like the following more readable (I am not actually suggesting names here, just an example): #define PY_LOCAL __attribute__ ((visibility ("hidden"))) ... void foo(void) PY_LOCAL; void bar(void) PY_LOCAL; ---------- _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue16745> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com