Ezio Melotti added the comment:

Note that while this works for the simple case, it doesn't work whenever you 
need additional tests or attributes that are specific for one of the two 
classes, or when you have additional base classes.  This is also not so 
uncommon.  I think the skip on the accelerated version might not be necessary 
in some situations.

IOW we have to trade between compactness, flexibility, and readability, and 
trying to improve one side will likely make other aspects worse.

I don't think there would be any problem at grouping the two 
import_fresh_module() in a single call that returns the two modules though.  (I 
would also avoid the use of pep399 in the names -- it's not really readable 
unless you can map pep numbers with their titles.)

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue17037>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to