Ben Hoyt added the comment:

That's right: if we have a separate scandir() that returns (name, stat) tuples, 
then a plain iterdir() is pretty much unnecessary -- callers just ignore the 
second stat value if they don't care about it.

I'd slightly prefer the name iterdir_stat(), as that almost makes the (name, 
stat) return values explicit in the name. But that's kind of bikeshedding -- 
scandir() works too.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue11406>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to