Nick Coghlan added the comment:

dir() will get me TracebackException as a name, 
help(traceback.TracebackException) will get me its signature. IDEs with 
autocomplete and signature tooltips will do the same.

There is nothing in those usage sequences to say "don't use __init__, use this 
redundant class method with the same signature instead".

I agree providing a "directly from an exception" constructor is essential for 
cases where you're working with a caught exception at the Python level. I don't 
agree with the idea of duplicating the required low level API under a different 
name so it doesn't *look* like a lower level API in the documentation.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue17911>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to