Cheryl Sabella added the comment: Thanks for all the info.
I've made another patch for textfile.py with removing ButtonFrame. I've also included test_textfile.py and help_about.py in the patch. I had worked on help_about yesterday, so if you don't like the button classes, I may need to undo it. However, since they do a lot of 'stuff' maybe it would be similar to the HelpText class in help.py? It seems more readable to me compared to when I first looked at the file. Although, the place_widgets is still messy. 2: Need to bookmark and spend time with this. For #5 and #8, it sounds like using f-strings is OK even though it only is 3.6+, so then super() should be OK too? 9: Yes, I've been doing that to test all my changes. It's nice to use since at times, I've lost the window entirely. And I get feedback in the console with the line error when it doesn't work. I also get to play with the settings to understand what something does. :-) New questions: 1. In help_about, I converted to all ttk widgets, so fg and bg don't work anymore. Should I try to add ttk.Style? For me, the dialog looks the same color-wise as it did before. 2. In help_about, there was an extra frame (frame_background). It looked the same with it and without it, so I removed it. Is that OK? 3. Forgot to ask yesterday, but the code with `self.text = text = ????` (and all the others with double assignment). I understand that the self.text is for unittest, but is there a reason to have both self.text and text? Just trying to understand so I know when to apply it and when not to. Thanks! ---------- Added file: http://bugs.python.org/file46916/textview.patch _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue30495> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com