Serhiy Storchaka <storchaka+cpyt...@gmail.com> added the comment:

> A fileobj property would be convenient, as you otherwise, for example, need 
> to pass an extra argument to routines that need both the csv object and the 
> underlying file object.

But you should already have this object for creating csv.reader() or 
csv.writer().

Even if keep the argument of the constructor as an instance attribute, there is 
a problem with naming this attribute. csv.reader works not only with files. It 
accepts arbitrary iterable.

>>> it = iter(['Spam, Spam, Spam, Spam, Spam, Baked Beans', 'Spam, Lovely Spam, 
>>> Wonderful Spam'])
>>> list(csv.reader(it))
[['Spam', ' Spam', ' Spam', ' Spam', ' Spam', ' Baked Beans'], ['Spam', ' 
Lovely Spam', ' Wonderful Spam']]

The dialect property is not a copy of the dialect constructer argument.

----------
nosy: +serhiy.storchaka
versions:  -Python 2.7

_______________________________________
Python tracker <rep...@bugs.python.org>
<https://bugs.python.org/issue33158>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to