Kyle Stanley <aeros...@gmail.com> added the comment:

Yury Selivanov wrote:
> I'd suggest to change to: "Return an iterator of coroutines.  Each coroutine 
> allows to wait for the earliest next result from the set of the remaining 
> awaitables."

The first sentence looks good to me, but I'm not certain about the second 
sentence, particularly "allows to wait". Instead, I'm thinking something like 
this might read better:

"Each coroutine represents the earliest next result from the set of the 
remaining awaitables, based upon the order of completion."

Thoughts?

----------
nosy: +aeros

_______________________________________
Python tracker <rep...@bugs.python.org>
<https://bugs.python.org/issue40405>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to