Irv Kalb <> added the comment:

Thanks Ned and Terry for your responses.

Ned: I am currently teaching a course where my students and I are all using 
Python 3.7 and the current Pygame 1.9.6, so unfortunately, I cannot update to 
the newer development release of 2.0.  I am also writing a book on OOP using 
Pygame, and that is currently dependent on the same Pygame release.

Terry:  I tried following your steps.  I opened the appropriate file 
(idlelib.filelist), and added the line at the appropriate place.  But when I go 
to save, I get a message:

[Errno 13] Permission denied: 

So I cannot save the file.

I tried opening the same file a simple text editor, BBEdit, and made the same 
change.  When I went to save I got a message:

Are you sure you want to unlock  You aren't a member of the group 
      Cancel   Unlock

I chose Unlock, saved and quit.  The Finder shows a new date for the file.  But 
when I double clicked on my Python 3.7 icon, or if I double click on any Python 
file, IDLE no longer opens.  

I went back into BBEdit, removed the new line, saved again.  Now I can open 
IDLE as before.  

I don't have a good feel for what files I am supposed to be "allowed" to edit, 
so I don't know what to try next.  If you have any suggestions about how I can 
add your debugging line successfully, I'm happy to help.


Python tracker <>
Python-bugs-list mailing list

Reply via email to