Dennis Sweeney <sweeney.dennis...@gmail.com> added the comment:

Do you have a particular use case for this? This is a backwards-incompatible 
change, and the existing behavior (the only false-y float being 0.0) is very 
old and well-established.

If this change was implemented, I suspect almost every use of it would benefit 
from a clarifying comment like

    if x: # check for NaNs
        ...

...so that is a hint to me that using the existing math.isnan() (or 
numpy.isnan() if you have numpy) is more explicit and therefore more readable.

I also think it would be confusing to have two different floats (0.0 and NaN) 
both be false-y.

----------
nosy: +Dennis Sweeney

_______________________________________
Python tracker <rep...@bugs.python.org>
<https://bugs.python.org/issue44770>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to