Case Van Horsen <cas...@gmail.com> added the comment:

I've spent some time working through the new hash function by re-implementing 
it for gmpy. Very elegant design.

I like _PyHASH_MODULUS better, too.

Regarding a hash function for complex types, I think documenting the existing 
behavior for PyComplex is sufficient. The magic number 1000003 could be 
documented in hash_info as 'multiplier' and _PyHASH_MULTIPLIER. The same 
constant, but a different algorithm, is also used when hashing a tuple.

I think hash(m/P) should preserve sign. It just seems more symmetrical. :)

----------
nosy: +casevh

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue8188>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to