Alexander Belopolsky <belopol...@users.sourceforge.net> added the comment:

I think this should be rejected.  The OP's premise was that t.timetuple()[7] 
was unreadable, but in the modern python, the same can be written as 
t.timetuple().tm_yday.  The later is only slightly less readable than the 
proposed t.yday().

For the other half of the proposal, Marc-Andre's mxDate code translates into 
only slightly more complicated stdlib datetime code:

def date_fromyday(year, yday):
   return date(year, 1, 1) + timedelta(yday - 1)

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue1436346>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to