Ezio Melotti <ezio.melo...@gmail.com> added the comment: > * the Py_UNICODE_JOIN_SURROGATES() macro should use Py_UCS4 as prefix since > it returns Py_UCS4 values, i.e. Py_UCS4_JOIN_SURROGATES() > * same for the Py_UNICODE_NEXT() macro, i.e. Py_UCS4_NEXT()
I'm not so familiar with the prefix conventions, but wouldn't that lead users to think that this macro is for wide builds and that they have to use Py_UCS2_* macros for narrow builds? If these macros are supposed to abstract the build type maybe they should have a "neutral" prefix. (But if the conventions we use say otherwise I guess the best we can do is to document it properly). > * in order to make the macro easier to understand, please rename it to > Py_UCS4_READ_CODE_POINT(); that's a little more typing, but still a lot less > than without the macro :-) The term code point is not entirely correct here. High and low surrogates are code points too. The right term should be 'scalar value' (but that might be confusing). The 'READ' bit sounds fine though, maybe 'READ_NEXT'? ---------- _______________________________________ Python tracker <rep...@bugs.python.org> <http://bugs.python.org/issue10542> _______________________________________ _______________________________________________ Python-bugs-list mailing list Unsubscribe: http://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com