Nice going! But ...
Could we extend the 'try' syntax for this instead of introducing
'with'? If I look at the translation it an augmented 'try'.
with EXPR as VAR:
BLOCK1
except EXCEPTION:
BLOCK2
could then be translated to
abc = EXPR
exc = (None, None, None)
VAR = abc.__enter__()
try:
try:
BLOCK1
except EXCEPTION:
BLOCK2
except:
exc = sys.exc_info()
raise
finally:
abc.__exit__(*exc)
Can the 'throw()' method be renamed 'raise()'? IMHO that makes much
clearer what happens.
Same thing with 'GeneratorExit', 'StopGeneration' more closely matches
'StopIteration'.
--eric
_______________________________________________
Python-Dev mailing list
[email protected]
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe:
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com