Hello, PEP 8 for function and method names: ----- Function Names
Function names should be lowercase, possibly with words separated by underscores to improve readability. mixedCase is allowed only in contexts where that's already the prevailing style (e.g. threading.py), to retain backwards compatibility. Method Names and Instance Variables The story is largely the same as with functions: in general, use lowercase with words separated by underscores as necessary to improve readability. ----- We need a clear style for function and method names now std lib uses "foo_bar" sometimes "foobar" and sometimes "fooBar". The use of lowercase with underscores is the default so the python std lib should use it in all modules. -> Python 3000 std lib Or should we switch to camelCase with lowercase first letter ? As most other Languages prefer this (Java, C#, C++, ...) bye by Wolfgang _______________________________________________ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com