Tristan Seligmann wrote:
> Greg Ewing <[EMAIL PROTECTED]> [2006-03-21 13:20:53 +1200]:
> > Gareth McCaughan wrote:
> > >
> > >    def f((x0,y0) as p0, (x1,y1) as p1):

> For maximal utility, this would affect the calling signature of the
> function, too: it would now have keyword arguments named p0 and p1.

I still think it hurts readability of the header
too much to be worth the benefit. To me it would
seem much clearer all round to write

   def f(p0, p1):
     x0, y0 = p0
     x1, y1 = p1

-- 
Greg Ewing, Computer Science Dept, +--------------------------------------+
University of Canterbury,          | Carpe post meridiam!                 |
Christchurch, New Zealand          | (I'm not a morning person.)          |
[EMAIL PROTECTED]          +--------------------------------------+
_______________________________________________
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe: 
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Reply via email to