On 3/6/07, Adam Olsen <[EMAIL PROTECTED]> wrote: > On 3/6/07, Guido van Rossum <[EMAIL PROTECTED]> wrote: > > On 3/6/07, Facundo Batista <[EMAIL PROTECTED]> wrote: > > > Guido van Rossum wrote: > > > > > > >> - I'll modify urlopen for it to accept a socket_timeout parameter, > > > >> default to None > > > > > > > > I'd call it timeout. There can't really be much ambiguity can there? > > > > > > Yes and no. For example, if I do a > > > ``urllib2.urlopen("ftp://ftp.myhome.com.ar/blah.txt", timeout=10)``, the > > > timeout is about the socket or about the file transfer? > > > > Think of it this way. "Timeout" doesn't mean the whole thing needs to > > be completed in 10 secs. It means that over 10 secs of no activity > > causes it to be aborted. > > IOW, It's an idle timeout.
That's not in wikipedia. :-) It's the only timeout that is available to us, realistically; the socket module calls it timeout everywhere. So I think that should be a good name for it. The argument name doesn't need to server as complete documentation. I don't expect we'll ever see another kind of timeout added to this same API, and if we do, we'll just have to pick a different name for it. ;-) -- --Guido van Rossum (home page: http://www.python.org/~guido/) _______________________________________________ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com