On Wed, Aug 11, 2010 at 8:45 PM, Antoine Pitrou <solip...@pitrou.net> wrote:
> On Wed, 11 Aug 2010 12:30:40 +1000
> Nick Coghlan <ncogh...@gmail.com> wrote:
>>
>> The second (#9396) came up in the context of the new cache decorators
>> added to functools, and allowing applications to choose their own
>> caching strategies. I suggested exposing the original (uncached)
>> function, and Raymond suggested that the easiest way to enable that
>> would be for functools.update_wrapper to add a new attribute that
>> provides a reference to the original function. Some time back, we
>> considered doing this automatically as an integral part of decoration,
>> but decided that wasn't appropriate. However, building it into the
>> explicit wrapping functions makes sense to me. To avoid namespace
>> conflicts, I plan to use "__wraps__" as the name for the reference to
>> the original function.
>
> I think it should be "__wrapped__".

Agreed, particularly since the relevant argument to update_wrapper()
is already called "wrapped".

Cheers,
Nick.

-- 
Nick Coghlan   |   ncogh...@gmail.com   |   Brisbane, Australia
_______________________________________________
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe: 
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Reply via email to