On Tue, Mar 15, 2011 at 11:50 AM, Terry Reedy <[email protected]> wrote: >> How would that work if you had a field named "replace"? I think >> Raymond's current design is as good as it's going to get. > > 'as_dict' is an unlikely fieldname. 're_place' is too, but that just shift > the '_' from '_replace'. No gain. I might prefer _asdict to _as_dict, but > not enough to change.
Probably a stupid idea (sorry) but one could just make asdict() and replace() public methods with the caveat that developers not use those as field names. cheers James -- -- James Mills -- -- "Problems are solved by method" _______________________________________________ Python-Dev mailing list [email protected] http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com
