On Mon, Feb 20, 2012 at 10:55 AM, antoine.pitrou
<python-check...@python.org> wrote:
> +def _relax_case():
> +    """True if filenames must be checked case-insensitively."""
> +    if any(map(sys.platform.startswith, CASE_INSENSITIVE_PLATFORMS)):
> +        def _relax_case():
> +            return b'PYTHONCASEOK' in _os.environ
>     else:
> -        return True

Wow, that's horrendously confusing. Please change the name of the
factory function to "_make_relax_case" (or something, anything that
isn't "_relax_case" would be an improvement).

Also, the docstring should be on the created functions, not the
factory function.

Cheers,
Nick.

-- 
Nick Coghlan   |   ncogh...@gmail.com   |   Brisbane, Australia
_______________________________________________
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe: 
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Reply via email to