Yes, I don't like the 'local' prefix too. How about '__dictlookup__'? It's just more self-describing.
Yury On 2013-09-09, at 2:23 PM, Jan Kaliszewski <[email protected]> wrote: > Is '__locallookup__' a really good name? In Python, *local* -- especially in > context of *lookups* -- usually associates with locals() i.e. a namespace of > a function/method execution frame or a namespace of a class, during > *definition* of that class... So '__locallookup__' can be confusing. > > Why not just '__getclassattribute__' or '__classlookup__', or > '__classattribute__'...? > > Cheers. > *j > > _______________________________________________ > Python-Dev mailing list > [email protected] > https://mail.python.org/mailman/listinfo/python-dev > Unsubscribe: > https://mail.python.org/mailman/options/python-dev/yselivanov.ml%40gmail.com _______________________________________________ Python-Dev mailing list [email protected] https://mail.python.org/mailman/listinfo/python-dev Unsubscribe: https://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com
