On Sun, 10 Aug 2014 13:12:26 -0700, Glenn Linderman <v+pyt...@g.nevcal.com> wrote: > On 8/10/2014 1:24 AM, Stephen J. Turnbull wrote: > > Actually ... if I were a fan of the "".join() idiom, I'd seriously > > propose 0.sum(numeric_iterable) as the RightThang{tm]. Then we could > > deprecate "".join(string_iterable) in favor of "".sum(string_iterable) > > (with the same efficient semantics). > Actually, there is no need to wait for 0.sum() to propose "".sum... but > it is only a spelling change, so no real benefit. > > Thinking about this more, maybe it should be a class function, so that > it wouldn't require an instance: > > str.sum( iterable_containing_strings ) > > [ or str.join( iterable_containing_strings ) ]
Sorry, I mean 'string.join' is how it used to be spelled. Making it a class method is indeed slightly different. --David _______________________________________________ Python-Dev mailing list Python-Dev@python.org https://mail.python.org/mailman/listinfo/python-dev Unsubscribe: https://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com