On 29.11.16 19:58, victor.stinner wrote:
https://hg.python.org/cpython/rev/7efddbf1aa70
changeset: 105395:7efddbf1aa70
user: Victor Stinner <victor.stin...@gmail.com>
date: Tue Nov 29 18:47:56 2016 +0100
summary:
Uniformize argument names of "call" functions
* Callable object: callable, o, callable_object => func
* Object for method calls: o => obj
* Method name: name or nameid => method
This change looks wrong to me. "callable" and "callable_object" are
better names for functions like PyObject_Call(), since it supports not
just functions, but any callables. "name" is appropriate name of the
parameter that denotes a method name, not a method object.
_______________________________________________
Python-Dev mailing list
Python-Dev@python.org
https://mail.python.org/mailman/listinfo/python-dev
Unsubscribe:
https://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com