Hello, here is my ideas of new keywords combinations : (the code is writed like this #code#. Sorry if I do some english mistakes)
1 - and pass if except This one is just a shortcut of # try : code here except : do something # Its syntaxe is #CODE and DO_SOMETHING if except#, it's more readable i think. It is usefull for code like this : #import A_WINDOW_MODULE and import A_UNIX_MODULE if except If DO_SOMETHING is replaced by #pass# it just skips the ligne (and the error) 2 - CODE if CONDITION else CODE I would like the #VALUE if CONDITION else OTHER_VALUE" can also executes code. Like : #Sign_in(user) if button_i_dont have_a_acount.press() else Log_in(user)# or #break if quit==True# If the #else# isnt present and the condition result is False, the interpreter don't executes that ligne What do you think about ? _______________________________________________ Python-ideas mailing list -- python-ideas@python.org To unsubscribe send an email to python-ideas-le...@python.org https://mail.python.org/mailman3/lists/python-ideas.python.org/ Message archived at https://mail.python.org/archives/list/python-ideas@python.org/message/XL67K4RPQGZVN5FBSX2MDUZHSQEWNSSY/ Code of Conduct: http://python.org/psf/codeofconduct/